Notifications
Clear all

Request: Flash able ROM for beta users

Page 1 / 5
AP756
(@ap756)
Trusted Member

Hoping that I'll be selected as a beta tester I want to make sure that I can evaluate all possible topics in detail. Therefore I ask to provide the beta testers a full copy of the ROM (just a link to the latest software is fine). Thank you in advance

Bye for now Fred

Quote
Topic starter Posted : 08/07/2021 7:52 am
Space_Bison
(@space_bison)
Eminent Member

AP756 (Fred) and Jerwam. It appears the folder topic for V1.5 testers has been struck from the forum. At least I can't locate it any more. Have you noticed that?

Space_Bison (Todd)

ReplyQuote
Posted : 30/09/2021 5:27 pm
jerwam
(@jerwam)
Trusted Member

Yeah, I went looking for it this morning. I wonder why it is gone.

ReplyQuote
Posted : 30/09/2021 5:43 pm
AP756
(@ap756)
Trusted Member

Todd and Jerwam, noticed that problem too. I think it's a temporary (and unintended) delete/hide, because I even can't find any posts from the last 10 days. Except this old thread, very often I get just a 404 error message. Something is mixed up.

Bye for now Fred

ReplyQuote
Topic starter Posted : 30/09/2021 6:21 pm
Space_Bison
(@space_bison)
Eminent Member

I have also asked them via the Indigogo comment thing. Although I used one of the links they had to the folder from a prior update of theirs. Asked why the 404 error.

Hopefully the get things working again.

PS: They asked me today to flash the V1.5 I have and sent a package with what maybe is the "new" firmware. In looking at the firmware file description the numbers it sported matched the current V1.5 firmware my tester device has (2.3.05). So I re-advised them of the tester device OS/Firmware number and asked if should in fact do the reflash.

Todd

ReplyQuote
Posted : 30/09/2021 8:25 pm
AP756
(@ap756)
Trusted Member

Todd, the names might not be consistent and they just forgot to set a new name. Or something is just messed up and they decided to flash your unit again (removing any problem and resetting to factory delivery state). I assume you don't have anything important on your CarDongle, just flash and start from scratch and report any new faults (if any). That's the life of a beta tester...

I'm still waiting for my/any CarDongle to arrive. Two samples were announced, but none went through customs, were sent back and are not to find anywhere (probably scrapped). Hope that changes in forseeable future.

Bye for now Fred

ReplyQuote
Topic starter Posted : 01/10/2021 11:15 am
Space_Bison
(@space_bison)
Eminent Member

Nothing important at all all. I did a factory reset on it once already, via the Android software reset thing. As they haven't said anything about it yet I'll give the reflash a go.

If anything happens, good or bad, I'll post it here.

Todd

ReplyQuote
Posted : 01/10/2021 12:21 pm
Space_Bison
(@space_bison)
Eminent Member

As of October 1, 2021 (AM) I re-flashed the Cardongle V1.5 tester with the firmware that I was provided. After flashing, the device Firmware now reads 2.3.05 (again). SW Version is 1.3.9. I then re-installed 2 different cell phones for use with the device via Mirroid. The 2 phones are a Huawei P30 Pro and a Realme 8. Both Hotspot and Bluetooth installed correctly for the phones within Mirroid. GPS was again working in Mirroid.

Unfortunately however, when I tried the newly flashed V1.5 in my 2018 Mitsubishi Eclipse Cross, the car system again did not recognize the device as a phone.

PS: AP756 (Fred), a post of yours on flashing steps was great.....after trying to remember how I flashed V1.0 many moons ago, I was getting nowhere fast. The UTube videos weren't helping much so I did a quick search here and found your old post, followed it and voila, success! Thanks man.

ReplyQuote
Posted : 02/10/2021 12:23 am
Space_Bison
(@space_bison)
Eminent Member

Additional to my last post. I emailed info@cardongle.com with the same report and a short video. Not sure what they'll come up with now. I should have also mentioned while in the car, the P30 reported that the device was connected to the hotspot with an IP of 192.168.43.223. Bluetooth was set to tethering.

Todd

ReplyQuote
Posted : 02/10/2021 12:27 am
AP756
(@ap756)
Trusted Member

Hi Todd, I'd like to help getting CarDongle to work. Unfortunately I can't test any of my suggestions because I still got no test sample :-(.

I'd like to try some developer options. First you have to find a way to enable developer options on your CarDongle. Therefore you need a way to get the full settings menu (different launcher like Car Launcher), tap 7 times on "About phone"-"Build number" and the you will find a new entry on settings system-developer options. In this menu change "default USB configuration" to PTP. Now disconnect from PC and try again in the car. If it works now we'll take the next step 🙂

Bye for now Fred

PS: No guarantee it'll work. I can't test... And thanks for reporting my flashing guide worked for you

ReplyQuote
Topic starter Posted : 02/10/2021 7:29 am
Space_Bison
(@space_bison)
Eminent Member

Hi Fred. I'm familiar with Developer's Mode so I'll throw in my disposable Google account, get a "setting" app and give your suggestion a whirl. DMode is one of the things I usually enable in all my Android devices.

Todd

ReplyQuote
Posted : 02/10/2021 2:14 pm
Space_Bison
(@space_bison)
Eminent Member

Well Fred, no luck with the PTP setting. Did the enabling and then tried the V1.5 in my wife's car. Used both my phones in the test as well. Nothing doing. The closest to actually doing something were 2 messages the head unit gave me. One with the Realme 8 was to check my phone screen to enable Android Auto (no alerts or anything were on the phone though) and the second message was with the Huawei P30 where the head unit flashed a brief "Unable to connect to Android Auto". I have since not seen that message again.

The above attempts were made with the Car Launcher app as default. I then retried with the CD Nitro launcher, reset as default, but had same result - car does not see this as a phone.

One thing to note this test V1.5 CD now has a GPS test app installed. It was set to open automatically. I went into CD settings and disabled its start but still had same result.

PS: Why are you not getting your test sample? Are you living in some country way off the beaten shipping/postal paths?

Todd

ReplyQuote
Posted : 02/10/2021 4:15 pm
AP756
(@ap756)
Trusted Member

Todd, I'm living in Germany. Unfortunately we got super-correct customs. If a parcel isn't declared exactly to the regulations they just send it back. Because the parcel was routed via UK (which is no longer in European Community) this happened - I suppose, because nobody could explain that to me.

Back to CarDongle. Next suggestion is to install Android Auto from AppStore to CarDongle and to enable Developer Mode in this copy of Android Auto. From your description I assume something (the bridge between CD and your car) is missing. No idea if that helps, but worth a try.

Another idea: It seems that some of the settings you make are not permanently saved in CD. The reason might be the rights given to that program or (was a common fault with phones in old days) CD tries to store settings in ROM, which is not possible.

Regarding the phone(s): From your description I get the impression that your phones try to connect to the car. This slot is already occupied from CD and your car gets confused. If I'm correct you may try to connect CD, then open the cars settings menu and route CD to the car (don't know how to describe this better). Then you can try to connect your phone to "hands free".

That's enough for the moment. Hope you enjoy testing 😉

Bye for now Fred

ReplyQuote
Topic starter Posted : 03/10/2021 9:13 am
Space_Bison
(@space_bison)
Eminent Member

Sorry to hear about your "by the book public servants/bureaucrats" Fred. Especially if they are mad at Brexit.....

This tester already has a version of Android Auto installed on it (5.9.604634-release) which Google Play can never update (it fails) as does Google Play Services. I did manage to enable Developer Mode though in this version.
I also tried to side-load an Android Auto for Phones APK however it won't install either as it needs Android 10 and the CD version is 9.
I'm also pretty sure that any setting changes I'm making either through the CD "Settings" app or Google settings are staying. At least when I remove and reinsert the CD into the laptop and look at stuff while in Mirroid they remain unchanged.
The Mitsubishi Car system has pretty rudimentary controls over the phone settings. I can either add or remove phones and that's about it. I'll maybe try deleting the "cars" from my phone's Bluetooth settings and see what happens. As for being a "tester" when I originally contributed to this project last fall I thought we'd get something that worked properly right out of the box, much like the AAWireless device I also backed. So for me being a tester is not something I wanted to do. So far I've had more interactions & help with you and Jerwam that from the CD people who are not leaving me with any great hopes for this thing. The old 1976 TV show "The Gong Show" springs to mind.

Todd

ReplyQuote
Posted : 03/10/2021 2:12 pm
Tommy
(@admin)
Member Admin

The other thread was corrupted. The site has a virus which is why we had to remove the rest of the site. We will revert the site back to the older version (backup) so we can restore that thread..... We'll also rebuild a better site with better forum. thanks everyone!!

ReplyQuote
Posted : 04/10/2021 10:43 am
Page 1 / 5
Share:

We are made up of a team of passionate programmers, industrial designers and Android lovers who wanted to innovate the way Android is used in modern day vehicles.

Where To Buy

Subscribe To Our Newsletter

Join our mailing list to receive the latest news and updates from our team.

You have Successfully Subscribed!