GPS is inaccurate/not working2021-02-20T19:16:38+00:00

Home Forum Forums Troubleshooting GPS is inaccurate/not working

Tagged: 

Viewing 15 posts - 91 through 105 (of 106 total)
  • Author
    Posts
  • AP756
    Participant
    Post count: 56

    Space_Bison, thanks for your feedback. Unfortunately I’m still waiting for my CarDongle, I’d like to put my hands on it to prove my theories and to find some workarounds…

    @Tommy please have a look into the “time setting problem”, it might help you to get CarDongle to work worldwide.

    I have hope for the future and I thank you all for keeping the forum constructive and with positive thinking.

    Bye for now Fred

    eng3
    Participant
    Post count: 10

    The time or timezone setting has nothing to do with the ability to get a GPS fix. It just determines your location based on the GPS clock of the satellites. It does need to use the time or time zone of your device. In fact, you can use GPS to get the current time (and software can use your position to determine your time zone).
    A common reset, is reset of Assisted GPS which uses your cellular signal. Your cell signal can give you a rough location which can help speed up the time to get a GPS fix. But it is not required to get a GPS fix. None of this matters for this device since it has no cell signal either.
    Basically, you can’t fix broken hardware with software. You can just try to work around it.

    skoka123
    Participant
    Post count: 2

    This is really frustrating. I hope the GPS issue is not a hardware issue. I am from India. The cost of shipping back and dealing with customs is too much of a headache. Can someone with a working GPS in Google Maps post the country they are using the CD in?

    Mahmood
    Participant
    Post count: 4

    The GPS app that should be used on our phone isn’t working I have given it location permission but it always says location permission not given. That’s why the GPS in CD won’t work because on our phone it doesn’t work. I upgraded and all is good only when driving the position doesn’t update automatically . If it’s software issue then it can be solved by collecting data or even user info from forums.
    If the GPS app in phone works correctly maybe then it continues giving position data to CD who knows

    Trasher83
    Participant
    Post count: 3

    @Mahmood You need to have wifi hotspot on for it to work, BT is not enough

    • This reply was modified 6 months ago by Trasher83.
    Trasher83
    Participant
    Post count: 3

    I found a post regarding the same issue in AAWireless/XDA forum. AFAIK Cardongles version of AA does not prohibit touching the screen after x-amount of touches (like it does normally) So is this the problem with CD? Devs could try this and if it’s the case, release a FW without removing the restrictions in waze

    https://forum.xda-developers.com/t/aawireless-general-discussion-and-support.4247677/page-9

    “I solved my problem !!! Hope it helps you vizzze, and others who experience bad location accuracy / zoom behaviour with Waze.

    Do not activate the tap limit bypass in the experimental features !

    I figured out it is not really just deactivating the limit, but makes the system think the car is stopped. Then GPS location is not accurate, and moreover, Waze doesn’t work really well. Google maps seems to handle it better but still, GPS location is still approximative.

    Once this option is deactivated, the experience is actually flawless. Waze is showing acutal speed, GPS location is accurate, zoom behaves normally.

    @DevAuto , IMHO it would be useful to add a disclaimer about this when activating this feature, even if is an experimental one. What I understand here is 100% of the users using the tap limit bypass will experience a bad GPS behaviour, so I’m pretty sure you are going to receive new requests regurlarly.”

    • This reply was modified 6 months ago by Trasher83.
    vlada011
    Blocked
    Post count: 11

    @Trasher83
    Don’t mix AAWireless with cardongle.
    They are two different things beside the fact that cardongle has faulty GPS.
    If you guys didn’t notice project owners changed description on Indiegogo. First when we backed device
    they claimed it is with GPS. Now they claim “GPS – Navigation works via Android Phone Screen Mirroring (firmware update coming March 20)”
    This means that we will never receive (already received fist one) dongle as we backed it.
    Also in comments they claim that redesign is needed and metal ring is interfering signal.
    Lets be clear. Device does not have working GPS. Only redesign of board and using GPS module will bring us what we backed.

    Trasher83
    Participant
    Post count: 3

    @vlada011 Maybe the devs assumed it was faulty and based on that tried to find alternatives (like the gps-app for phones) Anyways, I hope they at least try that fix since the restrictions are removed at FW-level.

    AP756
    Participant
    Post count: 56

    @Trasher83, good observation! Thank you. Because the “GPS-module” ist part of the SOC this will help US to get the system running. Latest after rooting… Hope, my dongle will arrive soon, I want to start working on it.

    Bye for now Fred

    azanatta
    Participant
    Post count: 6

    Well…
    First time I tried the new firmware it didn’t work at all, not sure why… maybe it was the cell phone I was using to share the internet connection.
    After that I tried other cell phone and Waze was working almost fine. From time to time it seems that the GPS connection was lost but it was almost working fine.
    But Google maps was not working at all. The only thing working was the initial GPS location but using google maps to get directions not working at all. It was always displaying GPS connection lost.
    Maybe a new firmware will fix it but I don’t know for sure.

    Iandix
    Participant
    Post count: 7

    Okay.. downloaded the update the via the update option that appears on the screen. While it was doing that I downloaded the beta of gps4dongle. Everything appears to be working well. Waze and maps both now work
    Thankyou for this workaround.

    andrea.paluzzi
    Participant
    Post count: 11

    @Tommy

    Are you still working on new firmware to solve GPS issue? with last firmware (16th March), Waze is OK. Google Maps NO. When we’ll can have a solution working with Google Maps?

    jerwam
    Participant
    Post count: 87

    The only proper fix for these devices as to the GPS is a hardware upgrade, still holding out hope that the CD team not only fixes it in a v2, but offers it to their backers at no charge. That hope is slowly deflating though, especially since they changed their stance from “includes GPS antenna” to “GPS works with phone mirroring” … not a good sign that they will actually fix it.

    Kinda sad cause that is the only reason I purchased mine, I don’t care to use it for video, or audio, or other apps. Those were merely a nice thing to have for me. The only reason I purchased my device was because I was supposed to be able to use it as a standalone device for my long trips. Now that I need to use so many apps on my cell phone, I need to keep that plugged in, so have stopped using the CarDongle, and it just sits in my desk drawer hoping for a v2 to get released.

    dallasnights
    Participant
    Post count: 9

    Agreed
    he GPS Dongle app provided is not working and nothing seems to work to get GPS working on my CD
    I do hope as an very early backer they do offer us a new unit FIXED with GPS as they are developing now at no charge and ship in the first batch when they ship in May or June or earlier if its ready

    Please let us know your plans for us people who already got our CD and very much not satisfied with the GPS isse

    Thank all

    dandin
    Participant
    Post count: 19

    I’ve been unsuccessfully trying to get the GPS sharing on GPS4Dongle on my phone to connect. The app will always say “Not Connected” on my phone no matter what I do.

    My workaround, which might be helpful to others is as below.

    Bluetooth GPS on CarDongle – googoo.android.btgps
    Bluetooth GPS Output on my phone – com.meowsbox.btgps

    I had to enable mock locations on the CarDongle in Developer options to use Bluetooth GPS. Bluetooth GPS Output is a paid app, you can use it for free (however there is a time limit of 10 minutes)

    Using these apps I can use Waze on my CarDongle. I have not tested with Google Maps, next time I go for a drive I’ll test it.

    Hopefully this helps those who can’t get GPS4Dongle to connect to their CarDongle

Viewing 15 posts - 91 through 105 (of 106 total)
  • You must be logged in to reply to this topic.
Go to Top