Updated Amazon app not showing videos2021-02-27T19:54:23+00:00

Home Forum Forums Troubleshooting Updated Amazon app not showing videos

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • Ztensa
    Participant
    Post count: 48

    I’m not sure if anyone is suffering from this but running the latest amazon app would only show a black screen, I could hear the audio and navigate around the app but just a black screen.

    If you download this version, it’s fine. Also turn off auto-update via wifi in Play Store.

    https://www.mediafire.com/file/ddikkduqzld9wfn/Amazon_Prime_Video_v3.0.264.71147_apkpure.com.apk/file

    Ztensa
    Participant
    Post count: 48

    If you download the apk above, it will work fine. Works on my 17 CRV

    jarredduq
    Participant
    Post count: 23

    Thank you so much!

    zr1v
    Participant
    Post count: 4

    I have the same issue with youtubetv. Wonder if there is a different version that works.

    lllsondowlll
    Blocked
    Post count: 23

    The issues are coming from the fact that the CarDongle can’t natively handle DRM content from the device to your head unit display. The APKs that are being used to display video are essentially outdated or hacked which is another thing to be nervous about when signing into a video service with your credentials. Unless you can find modded APKs the updates and clean APKs will not show video.

    Ztensa
    Participant
    Post count: 48

    Google vancedapps and download the manager. There you’ll be able to download vanced YouTube and YouTube music and vanced micro

    fetunchandrapatel
    Participant
    Post count: 6

    I posted this as a different thread on this forum and was directed here:

    I’ve been using my CD on my Volkswagen Tiguan. I got it all set up using Mirroid and did the OTA firmware update. Everything works when tested on Mirroid both when hotspotting off my phone or connecting to my home wifi. However, when I get into the car Disney Plus and Amazon Prime video both show a black screen but still play audio. Subs show as well. I tried several different Disney Plus APKs going back 2 versions too but nothing makes a difference. Annoyingly when I plug the CD back into Mirroid the picture comes up. It’s just in the car that it doesn’t seem to work. Can anyone help?

    If the comment above RE: natively handling DRM content is correct then how come I’m able to use DisneyPlus and Amazon Prime on Mirroroid? If CD can’t play that content then it wouldn’t work on any device but that’s clearly not the case.

    The only caveat to this is there’s just been and OTA update so I’m doing that while typing this. I’ll retest after the update and post the results on here.

    fetunchandrapatel
    Participant
    Post count: 6

    Brief addendum to my previous post, I read on this post:

    That a low dpi apk might work so I’m trying a low dpi version of Disney+ and will report back soon

    Tommy
    Keymaster
    Post count: 161

    we may need to add custom support for these apps

    fetunchandrapatel
    Participant
    Post count: 6

    @Tommy so I ran some tests today. Looks like the same issue is happening. When connected to Mirroid all apps run just fine but when connected to the car (VW Tiguan) Disney+ and Amazon Prime play audio and subtitles but no picture, black screen only. The low dpi apk made no difference at all either.

    These seem to be the only two apps affected, ALL other apps work fine. Some examples of working apps: Youtube, Netflix, Real Debrid, CinemaHD, BBC iPlayer, SmartersIPTV and many more.

    Please let me know if there’s something else I can do/test, thanks

    Tommy
    Keymaster
    Post count: 161

    @fetunchandrapatel We will need to add custom support for streaming apps other than netflix.

    CarDongle_Enthusiast
    Participant
    Post count: 18

    @admin
    No Tommy, the issue is Android system contains the Flag_Secure. Unless you plan to deodex and decompile each apk and provide a patched apk that breaks when the latest update releases you will need to focus on that.

    I was actually in the process of fixing this for you guys before you uploaded bad firmware that bricked my device and then basically told me to get bent when I asked for replacement or refund 😉

    Tommy
    Keymaster
    Post count: 161

    @CarDongle_Enthusiast you went ballistic everywhere and on other social media channels.

    I confirmed that that firmware wouldn’t brick the device. Even if it had, we were working with everyone to find a solution.

    All you had to do is ask for an address to send the unit back to us, and we would have re-shipped a new unit out to you. We even pushed you to the front of the queue as well. Oh, well, let bygones be bygones. We will have to add custom support in-house it looks like.

    CarDongle_Enthusiast
    Participant
    Post count: 18

    @admin
    Tommy

    I keep trying to post links containing the info you will need to fix the problem but the posts aren’t showing up so I compiled the relevant info in the link below.

    https://pastebin.com/raw/myXriHMg

    Tommy
    Keymaster
    Post count: 161

    @CarDongle_Enthusiast Cheers. I will show this with our dev team!

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.
Go to Top